A user posted to me on there that they have got a configuration working with BT Infinity without the use of the white modem. I saw that this was possible when Draytek announced their 2830 device to work with BT Infinity and after further digging around it appears BT removed that the white modem needs to be used under their T&C’s.

Anyway I recently took delivery of a lot of the Cisco 887VA Routers and a Cisco 2901, 2911 with EHWIC-VA-DSL-A cards so I took this opportunity to try the below configuration out:

This Config is a re-write of a previous post I done and is based and 100% tested on a Cisco 887VA

First thing is to Disable the ATM Interface (you cannot have the ATM interface enabled and use VDSL – its either or)

interface ATM0
no ip address
shutdown
no atm ilmi-keepalive

Next configure the VDSL Interface (Ethernet 0):

interface Ethernet0
no ip address

In the UK (BT Infinity) it uses VLAN 101 so you need to configure a Sub interface and tag the traffic: You need to set the dial-pool member to the same number used for the dialer interface

interface Ethernet0.101
encapsulation dot1Q 101
pppoe-client dial-pool-number 1

 

interface dialer 1
description **BT INFINITY**

mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname bt@btinternet.com
ppp chap password 0 password
ppp ipcp address accept
no cdp enable

Username and password does not matter for a HOME Connection but in for a BUSINESS connection you will need to specify username/password

I noticed I was getting a global IP of 172.X.X.X when I removed the “ppp ipcp address accept” command from Dialer 1. When put back I was getting a IP range in the range of 80/81.X.X.X and the internet worked correctly.

You just need to add the normal command’s in for inside/outside NAT etc. Briefly described config below:

interface BVI1
description **Internal Interface**
ip address 172.16.32.254 255.255.255.0
ip nat inside
ip virtual-reassembly in

ip nat inside source route-map INFINITY interface Dialer1 overload

route-map INFINITY permit 1
match ip address INFINITY

ip access-list extended INFINITY
permit ip 172.16.32.0 0.0.0.255 any

Router# show controllers vdsl 0

VDSL-1

VDSL-2

7 thoughts on “Cisco BT Infinity – No White Modem – Cisco 887VA

  1. Hi,

    I’ve been trying to get a Cisco 887 working with BT’s Infinity connection but I’m having issues and even after looking at your config I still don’t seem to be able to get it connected.

    My issues is something around the dialer and this is the error I am recieving.

    Feb 15 15:15:41.019: Di1 DDR: Cannot place call, no dialer string set.

    Just wondering if you could shed some light and did you recieve this error when first trying to get your connection up and running.

    I would like to remove the white modem if I can hence using the 887.

    Cheers

    Mark.

  2. I have a cisco 887m and I have bt infinity coming next week. Problem I have is I currently run 2 adsl connections one on the cisco and one on a another router.

    The cisco does all the access control and routing for it’s own adsl connection and the other router does the same for it’s connection.

    Want I want to do is keep the adsl on the cisco and as the other line is getting the infinity I want to be able to run that from the cisco too.

    So the main problem is routing the traffic over 2 internet connections and getting the cisco to talk to BT’s VDSL modem.

    Cisco Router details below

    Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.2(1)T, RELEASE SOFTWARE (fc1)

    Cisco 887M (MPC8300) processor (revision 1.0) with 236544K/25600K bytes of memory.
    Processor board ID FCZ1504CCQD

    4 FastEthernet interfaces
    1 ISDN Basic Rate interface
    1 ATM interface
    1 Virtual Private Network (VPN) Module
    256K bytes of non-volatile configuration memory.
    125440K bytes of ATA CompactFlash (Read/Write)

    MY idea is to reconfigure fasteth 4 to work on a seperate vlan and have that connect to the bt modem.

    Any idea’s or suggestions?

    1. It depends on how you want to talk to the BT VDSL Modem and if you want to keep it? Too run multiple Internet Connections you are going to need a bigger router something Small like a 1801 or 1901 Series will do the trick where you can put a HWIC-1ADSL card in for the ADSL and use 1 of the Ethernet Ports to connect to the VDSL Modem as a PPPOE Dialer.

      It then depends on how you want to route the traffic? You can load balance them but I wouldn’t recommend it as it just creates a headache I usually use the faster line for Primary Traffic and the Secondary line for incoming requests like SMTP, HTTP, HTTPS, VPN etc and you can also configure it as a failover for the primary line by using SLA’s.

      Hope this helps and happy to help with this but I don’t think you will achieve what you want with the 887M? Are you using an ISDN circuit on the router currently?

      You cannot use one of the 4 fastEthernet ports because they are just a switched layer 2 port not a layer 3 so you cannot use for WAN purposes.

      Adam

  3. I’ve seen this config used on 877’s with infinity but they don’t seem to get the full 40mb.

    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    switchport access vlan 101
    !
    interface FastEthernet3
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
    ip address 10.193.125.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Vlan101
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface Dialer1 description $FW_OUTSIDE$
    mtu 1492
    ip address negotiated
    no ip unreachables
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp chap hostname
    ppp chap password 0
    ppp ipcp route default
    !
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    ip access-list extended NAT permit ip 10.193.125.0 0.0.0.255 any

    no I’m not using the isdn. Currently I have the cisco on line 1 and a hacked bt homethub 2 on line 2

    the infinity is coming on line 2.

    so I have 3 choices

    configure the cisco to do both and hope for the best

    swap the lines they are on and use the cisco for infinity on line 2

    leave the cisco alone and reconfigure the homehub to use infinity.

    either the cisco and the homehub would need to be connected to the BT VDSL modem depending on which one ends up using infinity.

    which would you suggest?

Leave a Reply

Your email address will not be published. Required fields are marked *